保证服务质量的规范( 十 )


破坏 , 数据报不会被丢失 。此外 , 元素必须保证非一致的流不会影响给其他流的服务 , 提供
者鼓励去证实他们的实现是和流模型相近的 。
11实现例子
有几种算法和实现和流模型相近的 , 它们包括加权公平排队(WFQ)、Jitter-EDD[3]、
VirtualClock[4]和IBM提议的一种配置 , 一种好的理论上表述表明这些配置是一大类算法的
一部分 , 这种理论可以在[6]中找到 。
12使用例子
考虑到一个对于任何丢失或延迟的数据报不能容忍的应用程序 , 它使用Ctot和Dtot的
广播和流的TSpec值 , 来计算一个速率R的服务请求的延时界值 。假设R为[(b-M)/R*(p-R)/(p-r)] (M Ctot)/R Dtot 。
13安全考虑
本备忘录讨论了这个服务这样滥用来进行拒绝服务攻击 。这个服务不容许拒绝服务(虽然
在一定的条件下可能会降低)
附录1:用RSVP的保证服务的使用
和RSVP一起来使用保证服务在在参考[9]中指定 。本文档给出了需要支持期望保证服务
的应用程序的RSVPFLOWSPEC,SENDER_TSPEC,和ADSPEC对象 。RSVP协议本身在参
考[10]中有指定 。
14参考文献
[1]Shenker,S.,andJ.Wroclawski,"NetworkElementService
SpecificationTemplate",RFC2216,September1997.
[2]A.Demers,S.KeshavandS.Shenker,"AnalysisandSimulationof
aFairQueueingAlgorithm,"inInternetworking:Researchand
EXPerience,Vol1,No.1.,pp.3-26.
[3]L.Zhang,"VirtualClock:ANewTrafficControlAlgorithmfor
PacketSwitchingNetworks,"inProc.ACMSIGCOMM"90,pp.19-29.
[4]D.Verma,H.Zhang,andD.Ferrari,"GuaranteeingDelayJitter
BoundsinPacketSwitchingNetworks,"inProc.Tricomm"91.
[5]L.Georgiadis,R.Guerin,V.Peris,andK.N.Sivarajan,
"EfficientNetworkQoSProvisioningBasedonperNodeTraffic
Shaping,"IBMResearchReportNo.RC-20064.
[6]P.Goyal,S.S.LamandH.M.Vin,"DeterminingEnd-to-EndDelay
BoundsinHeterogeneousNetworks,"inProc.5thIntl.Workshopon
NetworkandOperatingSystemSupportforDigitalAudioandVideo,
April1995.
[7]A.K.J.Parekh,AGeneralizedProcessorSharingApproachtoFlow
ControlinIntegratedServicesNetworks,MITLaboratoryfor
InformationandDecisionSystems,ReportLIDS-TH-2089,February1992.
[8]Shenker,S.,andJ.Wroclawski,"GeneralCharacterization
ParametersforIntegratedServiceNetworkElements",RFC2215,
September1997.
[9]Wroclawski,J.,"UseofRSVPwithIETFIntegratedServices",RFC
2210,September1997.
[10]Braden,R.,Ed.,et.al.,"ResourceReservationProtocol(RSVP)
-Version1FunctionalSpecification",RFC2205,September1997.
Authors"Addresses
ScottShenker
XeroxPARC
3333CoyoteHillRoad
PaloAlto,CA94304-1314
Phone:415-812-4840
Fax:415-812-4471
EMail:shenker@parc.xerox.com
CraigPartridge
BBN
2370AmherstSt
PaloAltoCA94306
EMail:craig@bbn.com
RochGuerin
IBMT.J.WatsonResearchCenter
YorktownHeights,NY10598
Phone:914-784-7038
Fax:914-784-6318
EMail:guerin@watson.ibm.com