BOOTP 引导协议( 六 )


开始的行忽略 。
#commentline
homedirectory
genericname1pathname1
genericname2pathname2
...
%endofgenericnames,startofaddressmappings
hostname1hardwaretypehardwareaddr1ipaddr1genericnamesuffix
hostname2hardwaretypehardwareaddr2ipaddr2genericnamesuffix
...
这是一个特定的样例 。注重"硬件类型"数值同"AssignedNumbers"RFC中ARP章节 。
"硬件类型"和"IP地址"数值是十进制;"硬件地址"是十六进制的 。
#lastupdatedbysmith
/usr/boot
vmunixvmunix
tipethertip
watch/usr/diag/etherwatch
gategate.
%endofgenericnames,startofaddressmappings
hamilton102.60.8c.06.34.9836.19.0.5
burr102.60.8c.34.11.7836.44.0.12
101-gateway102.60.8c.23.ab.3536.44.0.32gate101
mjh-gateway102.60.8c.12.32.bc36.42.0.64gatemjh
welch-tipa102.60.8c.22.65.3236.47.0.14tip
welch-tipb102.60.8c.12.15.c836.46.0.12tip
在上述样例中,假如"mjh-gateway"是一个默认的引导程序,它将得到文件"/usr/boot/gate.mjh" 。
9 致谢
RossFinlayson等早先提出了两个使用讨论RARP[1]的TFTP引导的RFC 。
我们感谢NoelChiappa,BobLyon,JeffMogul,MarkLewis,和DavidPlummer的前期工作和
注解 。
10 参考文献
1.RossFinlayson,TimothyMann,JeffreyMogul,MarvinTheimer.A
ReverseAddressResolutionProtocol.RFC903,NIC,June,1984.
2.RossFinlayson.BootstrapLoadingusingTFTP.RFC906,NIC,
June,1984.
3.MarkLottor.SimpleFileTransferProtocol.RFC913,NIC,
September,1984.
4.JeffreyMogul.BroadcastingInternetPackets.RFC919,NIC,
October,1984.
5.DavidPlummer.AnEthernetAddressResolutionProtocol.RFC
826,NIC,September,1982.
6.JonPostel.FileTransferProtocol.RFC765,NIC,June,1980.
7.JonPostel.UserDatagramProtocol.RFC768,NIC,August,1980.
8.JonPostel.InternetProtocol.RFC791,NIC,September,1981.
9.K.R.Sollins,NoelChiappa.TheTFTPProtocol.RFC783,NIC,
June,1981.